Home · Excel Zeile nur ausgeben, wenn letzte Zeichen identisch
11/04/2021 at 15:46 in Neues

 

Die Spalten B2 und A2 werden ausgegeben, wenn der Wert in $H$1 damit von rechts betrachtet übereinstimmt. Die Anzahl der zu untersuchenden Zeichen ist in diesem Beispiel 2, kann aber auch 4 usw. sein.

A2 wird außerdem mit ";" in die Zeile geschrieben, um einen Separator zu haben ;-)

Das Ergebnis habe ich in Editor eingefügt und per ersetzen alls FALSCH FALSCH gelöscht.

Formel:

=WENN(IDENTISCH(RECHTS(B2;2);$H$1); A2&";")

<<< zurück